2

In our Drupal installation there is a menu item for the RSS feed, pointing to path de/rss for the German feed.

This path appears unchanged in the frontend and is invalid, hence results in a 404.

The correct URL is /de/rss.xml or just /rss.xml.

Weird thing is, that Drupal accepts the non-working path, while it rejects the correct ones:

The path 'de/rss.xml' is either invalid or you do not have access to it.

What's going on?

Note: I'm using the i18n module. And when I call /de/rss.xml it gets redirected to /rss.xml.

2
  • Are you using i18n module? Is your site in multiple languages? May 20, 2015 at 18:46
  • Yes. And when I call /de/rss.xml it gets redirected to /rss.xml.
    – Andy
    May 21, 2015 at 10:54

1 Answer 1

1

If you're using i18n module, and after you have installed module Variable, you should enable the i18n_variable module (one of the i18n submodules that requires the Variable module, among others).

Then navigate to /admin/config/regional/i18n/variable (= the Variables tab within ' Multilingual settings'). There you'll be able to specify all sorts of variables for which you want multi language support enabled also, using an appropriate sub-tab there, such as for "Site information", "Menu settings", etc.). Within sub-tab other, there is also "RSS feed for front page" (=The RSS feed for the front page, default is rss.xml). That "other" sub-tab should be between "Menu Settings" (1st sub-tab) and "Site Information" (3rd sub-tab).

I'd be curious to hear if your issue is resolved after you enable that option (by checking the checkbox).

5
  • Thanks for the tipp. In other there's only Pages or PHP code. In the tab Feed settings there's only Feed description. I couldn't find RSS feed for front page in any of the tabs /: Version is 7.35
    – Andy
    May 21, 2015 at 12:42
  • Looks like we're making progress / coming close. I slightly enhanced my answer (added the 'i18n_variable' part of it). Can you confirm you have that submodule enabled also? And then provide another status update (comment)? May 21, 2015 at 13:19
  • Module Variable translation is enabled.
    – Andy
    May 21, 2015 at 15:09
  • What's your answer to my PS in my comment in the question, ie: do you have only 1 language enabled (de) or maybe both "en" and "de" or so? May 21, 2015 at 15:10
  • de is default and en is enabled as well.
    – Andy
    May 25, 2015 at 11:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.