3

We used Drush on our server without any problems up until now. Actually we didn't do / change anything relating to Drush.

But now, on every Drush command we issue, we only get an error like so:

Drush command terminated abnormally due to an unrecoverable error.

Same error also occurs for Drush status. Only drush --version shows "Drush version: 6.6.0".

We installed drush via Composer. And the server is already restarted.

What can we do about this problem, which is a huge problem for us?

  • Did you site functioning properly in which you are running drush command? – Sumit Madan Jun 15 '15 at 7:41
0

Make sure your Drush commands are issued from the appropriate subdirectory of your website (change to the directory where your Drupal site is installed and try again).

Since your question did not specify that, it "might" be the reason why ALL your DRUSH commands are failing ...

Refer to this issue for other possible causes (things you may want to check).

If you recently enabled contributed and/or custom modules, try to temporary disable them to check if the Drush issue gets resolved by doing so.

  • We are sure about that ;-) We are using drush massively and know this "problem". – deelite Jun 15 '15 at 7:01
  • Could it really be a problem of a module? We are working on 3 Drupal installations at the same time. Different installations with different sets of modules. For all drush isn't working anymore. I'll try your link. – deelite Jun 15 '15 at 8:55
  • Oh yes, it was a problem within a module (config). We use drupal.org/project/shield for restricted access to the projects. In this module any of us disabled 'Allow command line access' in the module config... – deelite Jun 16 '15 at 11:28
  • Oeps, that's painfull ... but good for you that you did pinpoint the issue. Happy to read my answer somehow seemed to have helped! And thanks for the mention of the Shield module (didn't know about that module, may come in handy)! – Pierre.Vriens Jun 16 '15 at 12:21
  • I thought this issue could only be an generally problem because drush wasn't working in all projects. But the guy disabled it in all these projects where I tested drush. After reading your answer I cloned one of the projects and disabled ALL modules and drush worked. Ok, a module... Then I recovered the db from the backup and disabled 20 modules per step. After drush was working again I filtered by every single module. And so I found shield. But we didn't make any update of this module. So it only could be a configuration issue. You should have a look at the last dev of shield... – deelite Jun 16 '15 at 12:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.