0

Having messed up my dev site (running on Win 7 using Acquia Dev Desktop), I restored a backup I took a few hours ago with the Backup & Migrate module. Now when I click the local site name in Acquia Dev Desktop I get a Choose Language message from Drupal instead of my site. I'm certain I had this problem a few months ago, but I apparently did not make good notes because I don't know where I found the instructions to fix this problem. My guess is that the $database parameters are wrong in settings.php or maybe there's some other problem.

Help is appreciated!

0

There could be many reasons for this not working for you but as long as you've got the database backup and a copy of your existing codebase, you should be fine. Fixing DevDesktop database issues is a little tricky but the easiest way is to just create a new instance with the correct settings. Quick steps to do this:

  • We're going to be deleting the whole site instance using DevDesktop so you should make a backup of the folder and your database backup or at least move it outside of the DevDesktop folder.
  • Now from the DevDesktop application, delete your site and then create another one with the same name, etc. This will create a new database and a new settings.php file that is connected to it.
  • Finally, you'll want to copy your codebase back into this directory (making sure not to overwrite the settings.php or sites.php files that DevDesktop created) and then try the restore again using backup & migrate.
  • Thanks so much. I'm running again! I will create a new question about sites.php & settings.php. – Sam Stamport Aug 9 '15 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.