0

I'm having a super fish menu wih three layers of menu points but my second layer links do not seem to be expanding even tho "Show as expanded" is checked for the individual menu points (2nd level) that is selected as "Parent item" for the 3rd level page.

Some links:
menu point with submenus: http://www.lslib.ca/content/skwlax-daycare
Third level page(hidden from the menu): http://www.lslib.ca/content/admin

How can I get the third level to display?

EDIT 1

I don't exaxctly know how Superfish binds into the configration either.
Maybe a link to the page would help: http://www.lslib.ca/
Under Blocks, I only see Content assigned to a Region. I'm officially confused here... :o

EDIT 2

The name of the theme is Nexus Theme, under admin/appearance it says: Nexus Theme is a premium Drupal 7 theme. Developed by Devsaran.com.

In page.tpl.php I have the following:

<nav id="navigation" role="navigation">
  <div id="main-menu">
    <?php 
      if (module_exists('i18n_menu')) {
        $main_menu_tree = i18n_menu_translated_tree(variable_get('menu_main_links_source', 'main-menu'));
      } else {
        $main_menu_tree = menu_tree(variable_get('menu_main_links_source', 'main-menu'));
      }
      print drupal_render($main_menu_tree);
    ?>
  </div>
</nav>
  • Is this still an open question? Did you finish formulating it (it seems unfinished)? Which are the menu points that are not expanding in your example pages? – Stefanos Petrakis Mar 26 '16 at 9:27
  • @StefanosPetrakis hoops, yes I properly finished the sentence now. Yes, it still is a problem, the menu extension should be: Departments » Skwlax Daycare » Admin – stdcerr Mar 26 '16 at 17:40
  • Did you fix it? I can see the "Admin" option at the moment. – Stefanos Petrakis Mar 26 '16 at 21:47
  • @StefanosPetrakis no, I can't what browser? I'm using Chromium Version 49.0.2623.87 Ubuntu 14.04 (64-bit) – stdcerr Mar 26 '16 at 22:44
  • Windows NT 10.0 Firefox / 45.0 – Stefanos Petrakis Mar 26 '16 at 22:47
1

I would give this a try:

In the drupal bloc configuration just disable "Slide-in effect"

Quoting the last comment from this thread: https://github.com/joeldbirch/superfish/issues/30

Hope you get lucky with this, that whole github thread could be also interesting/relevant to your issue.

Update: This is apparently a theme specific superfish implementation, the respective theme being (most probably) Nexus

In order to deactive the effects that could be causing the error, you should edit the file sites/all/themes/nexus/js/custom.js at about line 7, commenting out the animation options:

//  animation:   { opacity:'show',height:'show'},   // fade-in and slide-down animation 

Hope this does the trick!

  • thanks for the link & the help but I have not been able to get it to work yet. I set all 4 block entries to Slide-in effect - None - but it still does nbot extend in Chrome - however, I also have to say that none of the blocs are actually assigned to a region. I'm a little confused here, all superfish blocks have the Region set to - None - – stdcerr Mar 29 '16 at 3:11
  • Where does superfish bind into your configuration? Is is part of a specific theme you are using? – Stefanos Petrakis Mar 29 '16 at 4:14
  • Please see EDIT 1 above – stdcerr Mar 29 '16 at 13:38
  • Did you get a chance to check the update: section in the answer? Did it work? Very curious about this... – Stefanos Petrakis Mar 29 '16 at 22:55
  • BANG! That was it (the update) I hadn't actually seen it! Great, Thanks a lot! – stdcerr Mar 30 '16 at 4:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.