1

I created a view of taxonomy terms, and then followed these steps to add the number of nodes using each term listed in the resulting view.

  • As Format, I selected HTML List showing Fields
  • As relationship, I added Content using field_blog_category, where field_blog_category is the field I added to a content type I created
  • I checked Use aggregration
  • I added ID (listed under the Content category) as new field
  • I set Aggregration type to Count for the new field (by clicking on Aggregration settings for that field)

It works as expected, except the fields are not in the same line.

screenshot

I checked the settings for both the fields, but I could not find a way to make them appear on the same line; even changing the settings for Rewrite results didn't help me.

Is it possible to have those two fields on the same line, without using Table as Format?

3

Yes. By default, a HTML List View displays fields wrapped in a couple of DIVs, a block-level element. Hence, it displays each field on a new line. To disable this, use the Style Settings > Customize field and label wrapper HTML checkbox for each field to use an element that isn't a block-level element (e.g. SPAN).

enter image description here

  • While using SPAN is the quickest & easiest way, just wanted to point out that you can also solve this with CSS As DEMOED Here – No Sssweat Jul 3 '16 at 0:44
  • You can use CSS for that too, but why would you use CSS styles when the Views module has already settings for achieving the same? – kiamlaluno Jul 3 '16 at 6:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.