0

We have a block on some pages which we like it without title, but when using < none > or leave it blank, it just showing the page title on the block title !

So how can we hide the block title ?

  • Is the block created using views? – Vamsi Sep 1 '16 at 9:26
  • @Vamsi On admin => Structure => Blocks => Add a new block – Sinf Sep 1 '16 at 9:36
  • Okay. How you are creating the block. Using views or using code. – Vamsi Sep 1 '16 at 9:43
  • @Soheyl So, there should be a Two titles, One on page which is original page title and one one Block, which is also a page title?, Right? – CodeNext Sep 1 '16 at 10:31
  • @Vamsi if by views u mean admin panel, yes I do like that :) – Sinf Sep 1 '16 at 10:46
1

@Rishi answer is perfect for hiding the block-title and it should work.

From your question, I can guess you are confusing the page title with the block title, or you want to hide the page title and the block title.

Let me give you an example. I created a page where I show a simple block with its body (four lines). The page has just its title.

In the following screenshot, I didn't hide the block title, so both the page and block title appear.

enter image description here

In the following screenshot, I hide the block title, so only the block body appears, together the the page title. Hence, it looks like the block title is replaced by the page title. Is this your issue?

enter image description here

First you need to understand, how pages and blocks work. They are two completly different things.

Now, I placed the trial block in the content region as shown in the following screenshot, which shows the page, with its title and content. After that, it shows the block with its title and content.

enter image description here

Hiding the block title setting it to <none> in the block configuration page works fine: It hides the block title as shown on the second screenshot from top. At this stage, it looks like the page title takes the place of the block title, and hiding the block title is not working. And that is your question. So, this myth is totally wrong. The page title is there, where it was. The block title got hidden by <none>, and the block body is where it should be.

Your question should be how to hide both the page and the block title.

For the block title, you can use <none>. For the page title, you need the Exclude node title module, which is the module I used to hide the page title as shown in the following screenshot.

enter image description here

The following screenshot shows the page after hiding block and page title.

enter image description here

See the differences between the first, second, and fifth screenshot.

1

In the Block title field, use <none> to display no title. Go to admin/structure/block/manage/system/main/configure: You will find the following description.

Override the default title for the block. Use <none> to display no title, or leave blank to use the default block title.

0

Removing the block title is easy, using CSS styles. You can add them with the CSS Editor module.

.block-title {
    display: none;
}

That will remove all the block titles. So if you want your block to have a custom title, you have to put it in the block, instead of using the block title, or block description when you create your blocks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.