1

I have worked with our host to increase our upload file size to 2GB. However, on one page it still states that the files must be less than 3MB. How do I change that? I am a Drupal novice so please bear that in mind.

The following is on a content type on our website (classified as a 'story'):

Files must be less than 3 MB. Allowed file types: jpg jpeg gif png txt doc xls pdf ppt pps odt ods odp.

So I am trying to increase the size to be 2GB as per what our host is allowing. How do I increase the file size to upload?

3
  • Can you even upload a file that size without a timeout?
    – Kevin
    Sep 28, 2016 at 15:53
  • I am not getting and error (not yet anyway). The following is on a page on our website (classified as a 'story) "Files must be less than 3 MB. Allowed file types: jpg jpeg gif png txt doc xls pdf ppt pps odt ods odp." I am trying to increase the size to be 2GB as per what our host is allowing. How do I increase the file size to upload? I apologize if I am not clear. Please let me know if this helps you. Thank you.
    – javablood
    Sep 28, 2016 at 15:56
  • Kevin, we have on a different 'page' at which our limit is 1GB.
    – javablood
    Sep 28, 2016 at 16:10

1 Answer 1

1

It sounds like the content type "story" has a 3MB limit set on that file field.

You can increase that limit by browsing to "example.com/admin/structure/types" and select the "Manage fields" tab (for the "story" content type). Find the field in question (the file upload field) and edit it. You should find a setting for the maximum upload size there.

If you'd like to learn more about fields, and specifically file fields, check out this Drupal.org resource and and this one as well.

Now, the other thing you will need to review is your .htaccess file. There are a couple of php flags you will want to review:

php_value post_max_size
php_value upload_max_filesize

Review the .htaccess file first because no matter what setting you set for your file field on the content type "story", it will be overridden by the setting in the .htaccess file.

6
  • Shane et al, thank you for your responses and assistance in solving this. And thanks for the education on 'content type', that helps!
    – javablood
    Sep 29, 2016 at 12:34
  • BTW the .htaccess file does not have anything for max size, this is what it has this: # Override PHP settings that cannot be changed at runtime. # PHP 5, Apache 1 and 2. <IfModule mod_php5.c> php_flag magic_quotes_gpc off php_flag magic_quotes_sybase off php_flag register_globals off php_flag session.auto_start off php_value mbstring.http_input pass php_value mbstring.http_output pass php_flag mbstring.encoding_translation off </IfModule>
    – javablood
    Sep 29, 2016 at 12:42
  • Yes, I'm pretty sure the .htaccess change is not required for your issue @javablood , as only one type of content was being affected. Some others may need to use the .htaccess fix for site-wide problems. P.S. please mark this answer as accepted if it fixed your issue. Glad we could help :)
    – hampercm
    Sep 29, 2016 at 14:37
  • How do I mark it as answered? Told you I was a Drupal novice! :-) I only see "Answer Your Question" and it did not look like that was it.
    – javablood
    Sep 29, 2016 at 16:31
  • There should be a check mark to the left of this answer that you can check to accept the answer. That's the case for all "Stack Exchange" communities like this one: meta.stackexchange.com/questions/5234/…
    – hampercm
    Sep 29, 2016 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.