2

Has anyone ever ran into this, UnmetDependenciesException? From googling there is quite a bit of talk about this, but so far no concrete solution.

enter image description here

and at the bottom (you can't see it in the screenshot) it says

dependencies in Drupal\Core\Config\UnmetDependenciesException::create() (line 84 of core/lib/Drupal/Core/Config/UnmetDependenciesException.php).

Drupal\Core\Config\UnmetDependenciesException::create('standard', Array) (Line: 460)
Drupal\Core\Config\ConfigInstaller->checkConfigurationToInstall('module', 'standard') (Line: 132)
Drupal\Core\ProxyClass\Config\ConfigInstaller->checkConfigurationToInstall('module', 'standard') (Line: 141)
Drupal\Core\Extension\ModuleInstaller->install(Array, ) (Line: 83)
Drupal\Core\ProxyClass\Extension\ModuleInstaller->install(Array, ) (Line: 1571)
install_install_profile(Array) (Line: 661)
install_run_task(Array, Array) (Line: 539)
install_run_tasks(Array) (Line: 116)
install_drupal(Object) (Line: 44)

I got this when I did a fresh install of LAMP.

I do not get this error when installing Drupal 8 in another LAMP server that I setup a long time ago.

This leads me to believe that it could be some php extension missing or some other package, but according to the installer, it doesn't say that I am missing anything.

Suggested solutions that have not worked:

  • Using a different browser with all history & cookies cleared.
  • Made sure no Core files are missing, since I did a wget and then unzip. Even tried diff core versions.
  • Selecting Minimal install.
4
  • I got the same errors the first time I tried to install Drupal 8 on the server I am using. I then used the Softaculous Apps Installer, and I didn't get any error. I suspect it was because some wrong access permissions on directories/files. – kiamlaluno Apr 29 '17 at 7:37
  • I suspect it was because some wrong access permissions on directories/files Initially it showed me permissions error, then I did a www-data -R drupal and it went away. So I doubt this is a perm issue, because if it was it would show a perm error and not allow you to get to the actual install step that I am in. – No Sssweat Apr 29 '17 at 8:54
  • Since the list given in the exception is a list of configuration objects, and since the configuration files are copied on the server together the other core files, I would think Drupal tried to copy those files in a different directory, and silently failed. I didn't investigate myself, since I was able to install Drupal 8 with a different method. Maybe you can find if that is the case, or not. – kiamlaluno Apr 29 '17 at 9:13
  • Yes, if you changed ownership on the entire dir to www-data that might have something to do with it (if it wasn't owned by the web user before that). I had a similar issue, not this exact one. – Kevin May 17 '17 at 21:09
1

I did another LAMP install and it worked. So IDK why it didn't before.

Although accidentally I managed to break it when using a bad php.ini file, so I guess that's one possibility.

1

So, I got this error trying to install Drupal 8.9.13 on MAMP Pro 6.3 using FireFox 87.0 on macOS Big Sur 11.2.3.

Switched over to Safari, and the installation completed.

Big lesson here, I suppose: Try a different browser!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.