0

Drupal 7.

The profile field is a very simple long text, text area, filtered html. When I try to edit it in my own regular user (no admin roles) page, with the standard permissions everyone has, I can do it no problem. A specific user has reported that he cannot do it at all. A message is displayed that his permissions are insufficient instead of the editable text area. A third user was kind enough to click his own edit button and has no problem just like me.

I double checked permissions (field permissions module is in use) and they seem absolutely ok. I tried to peek inside the database but don't see anything suspicious (I may not be looking in the right tables).

0

Check the text format in use for the field that the user cannot edit. Even if the user has permission to edit the field, the user will NOT be able to edit the field if the data is saved in a text format that the user does not have access to.

Make sure the user's field format is also filtered HTML.

If that doesn't work, use drush uli to log in as the user directly without changing his/her password and look at the problem with your own eyes-- sometimes users say something can't be done when they simply don't know how to do it.

  • You were absolutely right. I tried updating the db however it seems that there's more happening under the hood than I anticipated, setting the field format by editing it directly as an admin did the trick. – meh Oct 16 '17 at 13:18
  • @meh In general, never edit the DB directly unless you want to deal with problems that are nearly impossible to debug down the line. – Patrick Kenny Oct 16 '17 at 13:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.