1

My environment: UniServerZ XIII (a form of WAMP server), Drupal 8.4.3, Drush 9.x, Windows 10 Pro. Used Composer to install Drupal and also for Drush (as a site install). Windows PATH (for local user) settings include for Composer, MySQL, and Drush (at vendor/drush/drush from the Drupal project root). Bash is running thru MINGW64 (from Git for Windows).

[An aside: for those who find Drush throwing a bootstrap error, even though other Drush commands (such as core-status) work, what solved that one for me was adding MySQL to the Windows PATH.]

So Drush is 90% or more there for me.

What I need is to find is the configuration setting that sets the path/to/drush/script.

I've checked everywhere I can think of -- the config files in my folder and, in the Drupal project, the "vendor/bin" folder and the "vendor/drush/drush" folder and some of the latter's subfolders [why are two folders needed for Drush in a site install?].

When I run "core-status", the relevant line says this:

Drush script : C:/[path to Drupal project root]/vendor/drush/drush/drush

which file does exist, but (I'm guessing) isn't an effective command file in a Windows context.

Because: when I run "entup", the command returns a success code overall, but not before spitting out two error messages saying this:

[error] The command could not be executed successfully (returned: '[path to Drupal project root]/vendor/drush/drush/drush' is not recognized as an internal or external command, operable program or batch >file., code: 1)

I'm hoping that if I can find that config setting, I'll point the Drush script parameter to either "drush.php" or "dr.bat" instead of the "drush" file and that will fix what I hope is a last set-up problem in Drush on Windows 10. (The "drush" file itself seems to call drush.php.)

  • May have answered my immediate question: I edited an alias setting in my /.bashrc file, to point to drush.php, and that resulted in the "Drush script" line from core-status pointing to that file. The edit was: >alias drush="php C:/path-to-drupal-project/vendor/drush/drush/drush.php" And that allows "entup" to run, but now Drush throws off this fatal error: >Uncaught Exception: notify-send command failed. The error message suggests a potential edit in the drush.yml file as a fix. – DonRichmond Jan 4 '18 at 1:05

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.