0

I made a number of formatting changes to several basic pages using a Bootstrap-based premium theme. The changes accomplished what I wanted but I subsequently noticed that, when I visited the site as an anonymous user, the top roughly 1/2 inch of the content part of each page is not displayed. It's as if the top of the page is hidden behind the horizontal menu bar at the top of the page rather than appearing correctly a 1/2 inch down.

I backed out all the changes I could remember making but it's still broken. It displays correctly when logged in as either admin or an authenticated user. I don't know how to even begin troubleshooting this issue. Can anyone point me in the right direction?

3
  • 1
    You will need more details before someone understands your question and is able to asnwer it
    – GiorgosK
    Feb 20, 2018 at 6:53
  • to expand on @GiorgosK 's comment, do you mean the content its self or mean the css or what ? is this site live if so share link as this has way way way way way way too many different issues that could cause the "problem"
    – taggartJ
    Feb 20, 2018 at 8:42
  • Here is the site: secondary.makeminechocolate.org/node/53. This is just one page where you can see that the top 1/2 inch doesn't display. So part of the cartoon character's head is cut off as well as text to the right of it. This happens on most of the pages when anonymous but displays correctly when logged in.
    – SJM
    Feb 20, 2018 at 22:36

1 Answer 1

0

The body class in the custom-media.css is defining margin-top: 90px for the fixed header, you will need to increase this to match the size of your header.

You may need to include media queries to account for reactive menu changes.

It probably works when you are logged in because either the admin toolbar is modifying the margin or there is a rule specifically for being logged in that assumes the toolbar but you don't have it enabled.

4
  • Thanks for the response. The thing that confuses me is I have not touched anything in that file. It's a premium theme. So the file is the same for both secondary.makeminechocolate.net and tertiary.makeminechocolate.net. secondary is the broken one. tertiary uses the backup of the site from the day before the site broke. tertiary works properly, secondary does not. So I'm rebuilding the tertiary site to include the new code but, frankly, I'm spooked that the site could just break and not be fixable by simply removing the changes I had made to it that day.
    – SJM
    Feb 22, 2018 at 1:54
  • The tertiary site has the same problem. It is just not noticeable as the carousel image is larger and you don't see the cropping. Look at the raw image compared to what you see. E.g. the rabbit toys have bright color items at the top that are cut off on the site.
    – CG Monroe
    Feb 22, 2018 at 17:58
  • Ugh. Thanks, everyone. I didn't catch that both sites are broken. I will try to make the changes and see how it goes. I hope it's okay for me to keep this question open until I get it figured out. My sincere appreciation!
    – SJM
    Feb 23, 2018 at 16:03
  • Worked like a charm. I really appreciate the help.
    – SJM
    Feb 24, 2018 at 17:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.