0

I have a taxonomy called free-choices.But the contents are not listed when hyphen(-) in the taxonomy name.The pages with taxonomy name without hyphen is listing contents.How to solve this issue?I checked this validation criteria .But this is not working.How to solve this issue? enter image description here enter image description hereenter image description hereHow to solve this issue in the same views?

0

If you want a taxonomy term to be recognized wholly, then you definitely do not want to divide it with spaces, so uncheck the Transform dashes in URL to spaces in term name filter values.

Also check on the Use path alias instead of internal path option and set the correct path component. It shows set to 1, but most probably it's different component in the taxonomy path alias.

Additionally, try to use term ID instead of term name.

  • If it is unchecked also it is not working. – user3487918 Mar 20 '18 at 13:38
  • Try Use path alias instead of internal path and set the correct path component. – AltaGrade Mar 20 '18 at 13:41
  • Yes i checked the use path alias here.But not working – user3487918 Mar 20 '18 at 13:42
  • Change the path components, it is definitely not 1 in your case. Also I'd recommend you to register and start accepting asnwers as otherwise less people will want to help you with your questions. – AltaGrade Mar 20 '18 at 13:43
  • Thanks.But all other categories are working except with hyphen. – user3487918 Mar 20 '18 at 13:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.