1

When I try to edit taxonomy terms, or delete them, and I click on edit/delete, it redirects me to that term page instead.

I also have Devel module installed, and when I choose that option in the drop-down menu, it works.

I have tried almost everything.

  • URLs are OK; if I inspect the edit/delete buttons, the URL is the expected one. When it redirects me, that URL remains in the browser.

  • I thought it was a Drupal core issue. At the time I was using Drupal 8.5.3, but I am still having the problem after updating to Drupal 8.5.5.

  • I have removed all my custom modules/theme files (to check if it were my fault).

  • I changed the administrative theme from the Seven theme to the Bartik theme.
  • I cleared the cache and ran update.php several times.

The problem still remains, and I'm still not sure if it's an issue I have somehow caused, or it's a Drupal core issue.

Did anyone have a similar problem, or know what would be the problem?

1

Did you try to edit Taxonomy Term view /admin/structure/views/view/taxonomy_term I'm having issues with editing / deleting / translating taxonomy terms because I've edited taxonomy_term view. Disable taxonomy_term view and edit/delete should work.

  • No I didn't try to edit it, but after I have disabled it, it's working finally! Thank you very much!! It took me hours to solve this one. – lazarkoo Jul 12 '18 at 9:46
  • OK, if this is caused by the term view with /taxonomy/term/% path then this is connected to this issue: View with user/% path breaks login/logout on 8.5.x – 4k4 Jul 12 '18 at 11:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.