0

I am trying to dump a remote Drupal site to a local SQL dump file. In Drush 8 this worked a treat:

drush @site.alias sql-dump > ~/Dumps/dumpy.2019-02-19.sql

Now, if I run this command in Drush 9 (9.4.0) I see the raw SQL just printed on the screen.

If I add 2>&1 to the command, this does not help.

If I add a --result-file= this creates a file on the remote server (not what I want).

Does anyone have any ideas here?

  • 2
    Please try with the latest stable Drush, 9.5.2, or better yet, try out the 9.6.0-beta3 release. If you have problems, please submit a bug report to the Drush issue queue. – greg_1_anderson Feb 19 at 3:15
  • Yep. I was able to dump the database locally with Drush version : 9.5.2 – AjitS Feb 19 at 3:46
  • heh, the Drush Github issue queue said to raise questions here. Will see if I can update Drush. – wiifm Feb 20 at 0:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.