0

Since I updated to 8.6.10, I can no longer edit a new view. I can create a view but when I go to the main interface after clicking Save & Edit, nothings works. No matter what I click on, aside from the brief display of turning wheel, nothing happens.

I have checked the log and no error messages and strangely, existing views are working well.

Update: Error message from DevTool console shown below enter image description here

  • Are you using a contributed theme for administration? Have you checked the developer tools console for errors? This open issue at d.o. looks similar: drupal.org/project/drupal/issues/2988699 It might be helpful to report your problem there. – othermachines Mar 10 at 18:09
  • The open issue is exactly same as mine. I'll report my problem there too. Thanks. I've now added the error message from DevTool console. – Jio Mar 10 at 19:00
  • No problem! It may also be helpful to include which version you were updating from. – othermachines Mar 10 at 19:37
0

If the views are working but you cannot edit, then could something wrong with the views_ui module.

There are two differend modules:

  • Views: for views functionality
  • Views_ui: for changing views with the web browser at admin section.

Views do not need the Views-ui module activated. This is only for changing existing views. Therefore you can try to deactivate views_ui module and reinstall it.

(Cache clearing is always a good idea, but I think this have you done.)

  • Thanks James. Uninstalled & reinstalled Views UI with no luck. I can edit existing Views, my problem is I can't edit any new view I create. And yes, I did clear all cache. – Jio Mar 10 at 17:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.