0

When I create a filter, check the expose filter box, click save, then open the filter up again the exposed filter checkbox is uncheked...

I noticed when clicking save the filter is called: "Content: Assessment (or Unknown) | Settings" instead of "Content: Assessment (exposed) | Settings"

Anybody know what's going on here? I've tried creating an entirely new view and the same thing happens.


The field I am exposing is a simple taxonomy list.

I created a short video showing the issue: http://www2.intensiveintervention.org/views_issue/


I found a thread on a seemingly related issue: http://drupal.org/node/1343482 but this did not solve my problem.


Downgrading views to 7.x-3.1 did not have any effect.

  • 1
    The short answer is yes, exposed filters work in Views 3.3. Views is the most popular Drupal module and it would not have a major release where one of its major features, Exposed Filters, did not work. What kind of field are you trying to expose? How is that field configured? – Patrick Kenny Apr 10 '12 at 1:04
  • Do you have the latest version of cTools installed? – Chance G Apr 10 '12 at 18:51
  • I'm running the latest recommended: 7.x-1.0 – DesignGoggles Apr 10 '12 at 18:53
3

Okay I figured out the problem.

There is, as of today, incompatibility between Views and Theme Developer. If I disable Theme Developer views acts normally.

FYI for everybody else having this problem!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.