I have configured ldap sso and it is working so far for all Url paths except for the homepage.

I get authenticated on /user/login/sso and I get authenticated on /whatsoever but I don't get authenticated on / The settings for Automated SSO is checked and my settings for Apache look like this:

 <Location />
            AuthType Kerberos
            KrbAuthRealms xyz
            KrbServiceName HTTP/xyz
            Krb5Keytab /usr/local/apache2/conf/conf.d/drdc.keytab
            KrbMethodNegotiate on
            KrbMethodK5Passwd off
            KrbSaveCredentials on
            require valid-user

I did check the default excluded paths in the ldap sso module, but couldn't find the path / there.
I have tried to redirect every not authenticated user to /user/login/sso but somehow this results in "to many redirects" (I want to keep /user/login/ free for loggin in as admin user without kerberos)

if ($event->getRequest()->getRequestUri() != '/user/login' && $this->currentUser->isAnonymous()) {
  if (preg_match('/\/comment\-([\d]+)/', $current_path)) {
    $destination = str_replace('/comment-', '#comment-', $current_path);
    user_cookie_save(['destination' => $destination]);
  $url = '/user/login/sso';
  $response = new RedirectResponse($url);

Any idea?

1 Answer 1


This works now after unchecking this setting in the SSO-Module konfig:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.