0

enter image description here

I use unique field mapping, but instead of blocking the import on duplicates from CSV, it overwrites the data in Drupal and inserts the new value from the CSV file.

This is the default behavior with unique title field mapping:

"IF the title is duplicate THEN overwrite old item in Drupal with new item from spreadsheet"

But I'm looking for this behaviour:

"IF the title is duplicate THEN skip new item from spreadsheet, and keep old original item in Drupal intact"

I have field tamper, the item field AND the importer field all set to unique. It all works fine, but on duplicate feed imports, instead of preventing import of duplicate items, it overwrites the old field, and inserts the new duplicate...

My goal is for Drupal to PREVENT the duplicate field to be populated at all...the same way if you manually try to input a duplicate entry in manually imputing content, it shows an error and prevents you from submitting the form.

Is this even possible without custom code? Maybe with rules?

0

I have a hard time parsing your question. This is what I think you want:

  • If the source item has a title that already exists on the website, don't import this item.
  • If the source item has a title that does not exist on the website, import as a new item.

So if above are your only requirements, it would imply that you don't need to update existing content. In this case, the solution is:

  1. On the processor settings, set "Update existing" to "Do not update existing".
  2. On the mapping page, only set "Title" as unique.

From your story though, I sense that there might be more going on than just the above scenario, but I'm not exactly sure what it is.

  • yes, that's exactly what I need to do, it works! Thanks – yvesguy Jun 12 at 2:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.