Only the administrator can publish a node of content type Report. It is not using content moderation or groups though other content types are. All permissions are set for the "site admin" to create/edit own/others of this type. The only buttons available are "Save" and "Preview" and the published checkbox doesn't show for non-administrator users. Save sets as "Draft" even though it's not using content moderation.

  • There is no question here - just statements.
    – anonymous
    Mar 7, 2020 at 1:19

2 Answers 2


You can use the following module.

Override Node Options

The Override Node Options module allows permissions to be set to each field within the Authoring information and Publishing options field sets on the node form. It also allows selected field sets to be set as collapsed and / or collapsible.

  • Thanks for this recommendation. I try to add modules only if really needed. Since I would only need 1 piece of functionality from it and there is another way to do it with existing modules, I went that route.
    – shelane
    Aug 27, 2021 at 3:58

This answer discusses the different permission settings that would allow non-admins to have access to this. However, that would give them too much permission that they shouldn't be allowed to have in our case (both permissions show the "Warning: Give to trusted roles only;" message). Our work around was to create a "simple workflow" that would only have draft and published states so that these users can publish.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.