0

I'm running version 2, built Jan 9 2020, on a Windows 10 machine. I'm opening the command line via the dev desktop interface (via the small, black command line icon), and all drush commands run terribly slow. A drush cr can take 1-2 minutes, drush uli the same. Even a simple drush status drags.

I've learned that another colleague has the same issue, but still others don't, so I wonder if something isn't installed correctly. I also have lando installed but not running.

What do I have to do to troubleshoot or solve this?

  • 1
    This is most likely not a Drush problem, but rather that the shell (Git Bash) is terribly slow at all operations. I suggest reading stackoverflow.com/questions/4485059 and stackoverflow.com/questions/2835775 As a quick start, try export PS1='$' and see if the speed of Drush improves - taken from the first question above. – hansfn May 5 at 6:44
  • And all of your colleagues have the exact same machines, OS and setup? – leymannx May 5 at 15:05
  • @hansfn - by Git Bash, I assume you mean MINGW64, which is what comes up when I run Git Bash from the start menu. This runs all commands fairly fast. The issue is not in the Git Bash app anyway, it's in the Windows command line that comes up when you click the black launcher button in Acquia Dev Desktop. Also, when I run the export command, I get this: 'export' is not recognized as an internal or external command – Jav May 5 at 23:24
  • @leymannx, yes, all working with Windows 10 on a PC. – Jav May 5 at 23:25
  • 1
    @Jav Sorry, I forgot that Drush is run in Cmd, not Mingw64 / Git Bash, when using ADD. Then my comment wasn't very useful. I have you tried to increase debug when running Drush - to see where the time is spent? – hansfn May 6 at 6:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.