0

Using drush either globally or with a composer installed version, I get this double includes showing up in my fatal error (/includes/includes/):

include_once(/srv/www/htdocs/sites/drupal/includes/includes/entity.inc): failed to open stream: No such file or directory bootstrap.inc:3492 [warning] include_once(): Failed opening '/srv/www/htdocs/sites/drupal/includes/includes/entity.inc' for inclusion (include_path='.:/opt/php7.3/lib') bootstrap.inc:3492 [warning] Drush command terminated abnormally due to an unrecoverable error. [error] Error: Class 'DrupalDefaultEntityController' not found in include_once() (line 300 of /srv/www/htdocs/sites/drupal/modules/user/user.module).

Anyone ever see this before or have any ideas on why this is happening?

The site is located in the /drupal directory.

2
  • 2
    Which version of Drush? Drupal 7 needs Drush 8.
    – leymannx
    Jun 21, 2021 at 16:35
  • Good comment. Using drush 8.4.8 Jun 21, 2021 at 21:07

1 Answer 1

3

I think you might want to use Registry Rebuild to fix this, as it's most likely a problem with a borked registry.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.