0

I'm trying to configure simple_oauth to use with local Lando install of a Drupal 9 site with decoupled React frontend.

I've tried to manually generate the keys in the terminal:

$ openssl genrsa -out private.key 2048
$ openssl rsa -in private.key -pubout -out public.key

...placing the keys into a sibling directory of /web/ and /vendor/ called /keys/.

It throws these error messages:

"The Public Key file does not exist." "The Private Key file does not exist."

So then I tried pressing the "Generate Keys" button. When prompted for a "Directory for the keys", I input the same path to that /keys/ folder

Despite copying the output of a pwd from terminal directly into the field, it throws this error:

'Directory "/home/myusername/Desktop/react1/keys" is not a valid directory.'

What am I missing here?

2
  • You didn't define that "it" as is in "It throws these error messages..." but I assume that's a module. Is it? If so, is the directory readable by the web server user?
    – cilefen
    Mar 15, 2023 at 12:45
  • Yes, "it" is simple_oauth module. The tutorial I was following on Drupalize.me showed a standard file path, and I didn't yet realize that using Lando means I had to specify the directory relative to the "/app" project root
    – raresample
    Mar 15, 2023 at 23:19

1 Answer 1

0

I was able to get it working just by using "/app/keys" as the paths on ~/admin/config/people/simple_oauth, instead of the actual path on my machine as in the OP.

I suppose this comes down to me having an opportunity to learn more about Lando+Drupal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.