1

my installation: > drupal > lando composer install :ended up as seen below, I have run out of ideas what to do with this.

117/118 [===========================>] 99% Install of drupal/core failed

In Filesystem.php line 318:

[RuntimeException] Could not delete /app/vendor/composer/9b30b0b4/drupal-core-1272c35/modules/block/tests/modules:

Can anybody help? Thank you

ANSWER TO – leymannx : I did remove it but it doesn't help anything

I have reinstalled it again and it endded up the same except for the file is different.

  • Installing mexitek/phpcolors (v1.0.4): Extracting archive 117/118 [===========================>] 99% Install of drupal/core failed

[RuntimeException] Could not delete /app/vendor/composer/9e14d34d/drupal-core-1272c35/modules/config_translation:

that's strange really

ANSWER TO – Sssweat: I run windows and the chmod ug+w -R vendor/composer command doesn't work in my enviroment, neither in cmd nor VScode terminal.

I tried icacls vendor\composer /grant BUILTIN\Users:(OI)(CI)F which is suppose do the same thing but it had no positive effect.

2
  • 2
    Welcome to Drupal Answers!! What happens when you manually rm -rf /app/vendor/composer/9b30b0b4/drupal-core-1272c35/modules/block/tests/modules? You tried that already? Please update your question. Please don't try to clarify in comments. Thank you
    – leymannx
    Oct 25, 2023 at 19:53
  • From root folder try chmod ug+w -R vendor/composer and then lando composer install
    – No Sssweat
    Oct 26, 2023 at 9:12

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.