0

I had been developing a Drupal site locally and put it up online recently without much problems. Our server runs in PHP Safe Mode, but I've already got most of the website working nicely. The only weird thing that is happening now is that I, as the User 1/Admin with all permissions configured correctly and accordingly, have been unable to add any new nodes. I can manipulate views, add content types, change the appearance, use deltas and contexts, administer users, and do pretty much everything except add new content. I have been working around this by using Devel to generate some nodes, but this is clearly a flawed work flow. Oddly enough, I can view the list of current content and edit any node I please. I just get "Access Denied" when I got to http://www.example.com/node/add. For all content types. And they do show up in the administer menu, so I don't think it has anything to do with the content suddenly being unavailable.

Looking at the action/error log, I find that those "Access Denied" errors are happening to "Anonymous," even though I have clearly logged in. I have tried flushing all the caches, rebuilding permissions, and still no luck. I also tried making another admin account, and that user runs into the same problem. Does anyone know what this might be and how I can fix it? It's kind of important to be able to add content.

EDIT: This is on Drupal 7.14

  • 1
    "It's kind of important to be able to add content." I find it overrated to be honest ;) Are you running Drupal 6 or 7? – Clive Jun 28 '12 at 15:29
  • This is on Drupal 7. Updated the question – Laura Davila Jun 28 '12 at 20:14
1

Those who come and find this question unsolved can use the solution at d.o which is

Solved it!! It had to do with the .htaccess file! I needed to comment the following with regard to SSL Certificates.

# SSL Certificates
#  RewriteCond %{HTTPS} !=on
#  RewriteRule (user|admin) https://%{SERVER_NAME}%{REQUEST_URI} [L,R]
#  RewriteCond %{HTTPS} !=off
#  RewriteRule (node/*/edit|node/add/*) http://%{SERVER_NAME}%{REQUEST_URI} [L,R]

I am not entirely clear on why it suddenly worked, but obviously it has something to do with these rewrite rules.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.