I have the Content Access 7.x-1.2-beta1 module installed. I would like to enable access to a few basic pages, not all of them, for everyone including unauthorized users. I only see how to change the access for control for specific users or for all nodes of one type. How would I fix this? thanks!

  • I can't find any reference to a module called "access control"...is it possible you mean Content Access? – Clive Jul 18 '12 at 17:01
  • yes sorry! Content Access 7.x-1.2-beta1 – hollyh Jul 18 '12 at 17:10

Content Access has "Per content node access control settings" available for each content type.

If you navigate to the "Access control" tab for your content type (or navigate to admin/structure/types/manage/content_type/access) you should see the following fieldset:


As the description suggests, once you've enabled that setting each piece of content of that content type will have an 'Access Control' tab. From there you can decide which roles should be able to access that individual piece of content.

This is what the 'Access Control' tab looks like once you've enabled that setting:

enter image description here

| improve this answer | |
  • this just enables it per user, not per role – hollyh Jul 18 '12 at 17:59
  • Nope, it lets you choose roles too. I'll put another screenshot in the answer – Clive Jul 18 '12 at 18:00
  • 1
    Not sure what to say to be honest, I've looked at the code for the node access page (content_access_page()) and it only has settings for roles, not users, so I don't know how you're getting a list of users on that page. Are you sure you've got the beta1 version installed and not the dev version or an old version or something? – Clive Jul 18 '12 at 18:41
  • 1
    It's the fieldset at the top of the screenshot on the left where you select permissions by role. I wonder is it the fact that the fieldset looks identical to the one on the node type settings page that's causing the confusion? The one on the 'Node Access' page is specific to that node, it's not the same one as on the node type settings page – Clive Jul 18 '12 at 22:56
  • 1
    Yeah permissions are always a tricky one! You should un-check 'anonymous user' from 'view any public content' in the global (node type) settings, and then on an individual node basis go and enable/disable the same permission based on whether or not anonymous users should be able to access that specific node. So you're essentially implementing a DENY FROM ALL access control list that's overridden on a per-content basis. Does that help? – Clive Jul 18 '12 at 23:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.