0

I am installing Drupal 7 on a subdomain example.com/exampledev2 and I am running into problems with .htaccess. Meaning when I put the files in the root for the first time I get a 500 Internal Server Error, but if I rename it to .htaccess_off or something I can begin installation. Then when I get to the last step, after filling in the site info and creating a user, I click the continue button and I get a Error 500 Internal Server error. I am assuming this has something to do with having .htaccess no longer working, but I can't turn it on, or I get the error before installation. Any advice on how to change the file so I can use it?

EDIT: This is the .htaccess file that finally worked for me:

# Apache/PHP/Drupal settings:
#

# Protect files and directories from prying eyes.
<FilesMatch "\.(engine|inc|info|install|make|module|profile|test|po|sh|.*sql|theme|tpl(\.php)?|xtmpl)$|^(\..*|Entries.*|Repository|Root|Tag|Template)$">
  Order allow,deny
</FilesMatch>

# Make Drupal handle any 404 errors.
ErrorDocument 404 /index.php

# Various rewrite rules.
<IfModule mod_rewrite.c>
  RewriteEngine on

  # Block access to "hidden" directories whose names begin with a period. This
  # includes directories used by version control systems such as Subversion or
  # Git to store control files. Files whose names begin with a period, as well
  # as the control files used by CVS, are protected by the FilesMatch directive
  # above.
  #
  # NOTE: This only works when mod_rewrite is loaded. Without mod_rewrite, it is
  # not possible to block access to entire directories from .htaccess, because
  # <DirectoryMatch> is not allowed here.
  #
  # If you do not have mod_rewrite installed, you should remove these
  # directories from your webroot or otherwise protect them from being
  # downloaded.
  RewriteRule "(^|/)\." - [F]

  # If your site can be accessed both with and without the 'www.' prefix, you
  # can use one of the following settings to redirect users to your preferred
  # URL, either WITH or WITHOUT the 'www.' prefix. Choose ONLY one option:
  #
  # To redirect all users to access the site WITH the 'www.' prefix,
  # (http://example.com/... will be redirected to http://www.example.com/...)
  # uncomment the following:
  # RewriteCond %{HTTP_HOST} !^www\. [NC]
  # RewriteRule ^ http://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
  #
  # To redirect all users to access the site WITHOUT the 'www.' prefix,
  # (http://www.example.com/... will be redirected to http://example.com/...)
  # uncomment the following:
  # RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
  # RewriteRule ^ http://%1%{REQUEST_URI} [L,R=301]

  # Modify the RewriteBase if you are using Drupal in a subdirectory or in a
  # VirtualDocumentRoot and the rewrite rules are not working properly.
  # For example if your site is at http://example.com/drupal uncomment and
  # modify the following line:
  RewriteBase /mysite
  #
  # If your site is running in a VirtualDocumentRoot at http://example.com/,
  # uncomment the following line:
  # RewriteBase /

  # Pass all requests not referring directly to files in the filesystem to
  # index.php. Clean URLs are handled in drupal_environment_initialize().
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteCond %{REQUEST_URI} !=/favicon.ico
  RewriteRule ^ index.php [L]

  # Rules to correctly serve gzip compressed CSS and JS files.
  # Requires both mod_rewrite and mod_headers to be enabled.
  <IfModule mod_headers.c>
  # Serve gzip compressed CSS files if they exist and the client accepts gzip.
  RewriteCond %{HTTP:Accept-encoding} gzip
    RewriteCond %{REQUEST_FILENAME}\.gz -s
    RewriteRule ^(.*)\.css $1\.css\.gz [QSA]

    # Serve gzip compressed JS files if they exist and the client accepts gzip.
    RewriteCond %{HTTP:Accept-encoding} gzip
    RewriteCond %{REQUEST_FILENAME}\.gz -s
    RewriteRule ^(.*)\.js $1\.js\.gz [QSA]

    # Serve correct content types, and prevent mod_deflate double gzip.
    RewriteRule \.css\.gz$ - [T=text/css,E=no-gzip:1]
    RewriteRule \.js\.gz$ - [T=text/javascript,E=no-gzip:1]

    <FilesMatch "(\.js\.gz|\.css\.gz)$">
      # Serve correct encoding type.
      Header set Content-Encoding gzip
      # Force proxies to cache gzipped & non-gzipped css/js files separately.
      Header append Vary Accept-Encoding
    </FilesMatch>
  </IfModule>
</IfModule>

EDIT: I think the problem was not totally the htaccess file. The file did "direct" me to a WSOD page if it wasn't fixed, but I don't think it was the reason that when I got to the end of the install process I got an Error 500 screen. I think this was cause by having incorrect access to the database? During the process of install I may have changed the password, and then not updated it in the install.php process. Anyways I got the site up and working and will give some credit to MPD because it is a good answer.

3

It sounds like you aren't actually running in a subdomain, but rather a subdirectory. If you really are in a subdirectory, you you need to have .htaccess read (line 98ish, without the leading #)

RewriteBase /exampledev2

A 500 error typically means that something went wrong with Apache and/or PHP. In general, it isn't a syntax error or anything else in code, but usually something configuration related.

The WSOD page should be some help. You really need to see the Apache error_log to see exactly what went wrong.

If I had to guess, your setup is disallowing one or more directives in the .htaccess file. If you are on shared hosting, this is a real possibility.

Nearly everything in .htaccess is feature detected via <IfModule> directives, but there are a few things that may be disallowed. I have worked on systems where the Options can't be overridden. Try commenting out those lines. Drupal should still work, though there may be some security implications by not having the Options -Indexes.

If you comment out those lines, and everything works, then you need to talk to your sysadmin about how to fix this long term. Ideally, you shouldn't need (or want) to do that.

  • Congratulations! Welcome in the 10K user arena. :) – kiamlaluno Sep 11 '12 at 1:01
  • Yes Part of the problem is that this site is set up on a university system, which has its own servers, and its own section of sysadmins, who I am not sure would love to share the apache error log. I did get it installed, with the .htaccess named something else. I will post the contents of the file that we have working on the site now. – Draedalus Sep 12 '12 at 19:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.