0

My Drupal 7 website has no layout (CSS and JS is messed up) and is getting the following error message:

The specified file /tmp/filestW97L could not be copied, because the destination directory is not properly configured. This may be caused by a problem with file or directory permissions. More information is available in the system log.

The /tmp/ directory at the root level has 777 permissions. I think the directory the error message is referring to, as there are files with similar names in it. I'm puzzled as to why Drupal cannot access that directory.

It does have 80,000 files in it. Could it be too full?

I'm assuming that /tmp/ is the "destination directory". Am I correct?

I'm on a VPS running Centos. The VPS has plenty of resources and I tried rebooting it in case that might help.

I don't think I did anything to cause this error, as it happened when I was not working on the website. Is it possible that a CPanel update from the past several days did it?

I cannot read the system log, as the admin user cannot log in (I get blocked by an anti-spam module that requires JavaScript enabled). Is the system log the same thing as the watchdog table?


I fixed the problem. I did several things. I think flushing the drupal cache was the solution that worked, but I am not 100% certain.

  • It looks like the destination directory is "public://css". Watchdog is also giving me: "Unable to find the wrapper 'public' - did you forget to enable it when you configured PHP? – Aaron Kreider Sep 20 '12 at 20:48
  • 1
    First of all I'd use Drush to disable that spam module so that you can log in - a site with no admin access is utterly useless to the admin person... the logs should shed some light on it... Oh, and the destination directory is where the file in /tmp is being sent to, not tmp itself. Cheers Steve – Steve Sep 20 '12 at 20:50
  • Now I never setup the wrapper "public". So something else must have changed it, possibly cPanel. Where is it defined? – Aaron Kreider Sep 20 '12 at 20:56
  • Similar error to this one: stackoverflow.com/questions/12471482/… Except that I don't get the white screen of death. My errors are coming from public_html/includes/file.inc as well. – Aaron Kreider Sep 20 '12 at 21:00
  • 1
    possible duplicate of Configuring the temporary directory – Patrick Kenny Jan 25 '13 at 9:14
2

CSS and JS are stored in files/ folder. This folder must writable in order for Drupal to store the aggregated files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.