1

I am having a problem with multilingual settings. Here is my site URL http://centriumcapital.com/centrium. Everything is working fine but I just want when someone requests http://centriumcapital.com/centrium the default language should be French and also content of the home page also should in French.

I added code in settings.php file to make French language as default language it selects the French language as default but content is still from English language.

  • are you using Locale module ? – mohit_rocks Dec 17 '12 at 9:52
  • Internationalization and some other modules – Nadeem Dec 17 '12 at 9:54
  • My website is complete except this issue. if i use locale module what should effect on my rest of site/work which is almost completed – Nadeem Dec 17 '12 at 10:27
  • It will not affect other parts of site, but be aware and don't do it directly on live site. Do it on localhost. check whether it satisfies your usecase or not, and then upload the site – mohit_rocks Dec 17 '12 at 10:28
2

Check out this Page. You can set this using locale module and i18n translation module.

| improve this answer | |
  • My website is complete except this issue. if i use locale module what should effect on my rest of site/work which is almost completed – Nadeem Dec 17 '12 at 10:03
  • It will not affect other parts of site, but be aware and don't do it directly on live site. Do it on localhost. check whether it satisfies your usecase or not, and then upload the site – mohit_rocks Dec 17 '12 at 10:26
  • but i am already using locale and i18n translation modules. and everything (translation of blocks , pages and string) is working fine but i can't set French front page as my site default home page centriumcapital.com/centrium where centrium is directory at server that contains my development project. – Nadeem Dec 17 '12 at 14:58
  • Can't you set site's front page as this url centriumcapital.com/centrium/fr , if it is not creating a interrupt with other features – mohit_rocks Dec 17 '12 at 15:21
  • thanks for your help. Problem was in Browser default language. i unchecked this from Configuration->Regional & Language->Languages. – Nadeem Dec 17 '12 at 16:28
1

Finally I got the problem. in the languages setting Browser default language was enabled. so i just unchecked browser language and it is working fine now.

Thanks to mohit_rocks

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.