0

I have watched and read quite a few guides/tutorials on this subject and they each leave me with a blank block.

I am trying to create a related content module. My content is tagged with multiple terms.

I go and create a block view and go to contextual filters. I add the content: has taxonomy term ID. Then I add the "Taxonomy term ID from URL", slect the correct vocabulary, filter to items that share any term, click reduce duplicates and click apply.

Then I create the content:nid contestual filter and the block wont appear.

I have pathauto installed and I have a feeling it might be an issue with that. I cannot use the term id in my content paths.

I have been at this for a while. Any help on what I am doing wrong is greatly appreciated.

  • What do your URLs look like? Why can you not use the term id in your content paths? – Patrick Kenny Jan 20 '13 at 9:38
  • Please note this is just my rough draft for the site. www.blog.designsourcemedia.com. I dont think the problem is pathauto anymore. I created the contextual filter with Content: Has taxonomy term ID. Clicked Taxonomy term ID from URL for the type. Clicked Load default filter from term page and load default filter from node page. I click Limit terms by vocabulary, and tags. I turned Filter to items that share any term. – amiller Jan 20 '13 at 9:48
  • If you review the me3 and the japanese game see each other, but the dmc article has nothing on its side. This might be because of order but I dont know why it would effect it. – amiller Jan 20 '13 at 9:51
  • I have answered a question similar to this in another link see if that helps drupal.stackexchange.com/questions/57359/… – Mohammed Shameem Jan 20 '13 at 10:20
1

Pathauto module doesn't have to do anything with this view. I think you are not supplying any default value to contextual filters used in your block type of view.

For creating the related content view, please try following steps

  1. Create a Block type of display.

enter image description here

  1. Add Contextual filter for the taxonomy term -> goto settings of this filter -> select "default value" -> select "taxonomy term id from url" -> select limit by vocabulary -> select "vocabulary" -> select appropriate option from "Multiple-value handling" -> expand "more" fieldset and set allow multiple values.

  2. Enable Aggregation settings, and add the same taxonomy field in sort criteria and from aggregation settings select "COUNT DISTINCT"

  3. Add "Nid" as contextual filter -> go to settings -> select "default value" -> select "Content Id from URL" -> From "more" fieldset -> select "Exclude" - now results will not show the current node. enter image description here

Place this block now on your node page, and this block will list all the related content.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.