0

I am running a Drupal Commerce Kickstart 1 on top of it (D7)site on localhost/xampp (1.7.7).

Now: When I go to Content Type (/admin/structure/type), and click Edit on a given type or New Content Type, i get the white screen or a server 500 error. I can access manage fields and manage display on the same page. When I go to drupal error logs, there is no trace of the error. Neither can I find a trace of the problem in /opt/lampp/log/error_log. Tried to increase allowef script time / php memory limit in php.ini - no result.

The site works without problems on a remote testing server, and has been working without problems for a long time locally. So most probably it's local configuration, but I am not sure what to do.

Maybe some of you have an idea about what can I do?

  • PHP Fatal Error should be logging to syslog. Have you checked there? – Triskelion Mar 13 '13 at 18:45
  • when I do 'tail /opt/lampp/log/error_log' just after generating this error, I get '[Wed Mar 13 18:31:00 2013] [error] [client 127.0.0.1] PHP Fatal error: require_once() [<a href='function.require'>function.require</a>]: Failed opening required '/opt/lampp/htdocs/woo/profiles/commerce_kickstart/modules/rules/includes/rules.core.inc' (include_path='.:/opt/lampp/lib/php') in /opt/lampp/htdocs/woo/includes/bootstrap.inc on line 3066' - that is, only one such error from more then an hour ago (during which i retried it many times with cache clearing, php memory etc). – Dalmaz Mar 13 '13 at 18:52
  • Is the rules.core.inc file missing? If it is present, does the web server have permission to read and execute? – Triskelion Mar 13 '13 at 19:52
  • In fact, everything is OK with that file. It's just an error message form another drupal install on the same xampp, in which i tried to replicate the install that was (and still is) working on the remote server. The error reappered, and I tried to move the modules to standard location /sites/all/modules, so at fires the system failed to find the file. Still, there is no trace of any error anor 500 message (which were plenty – Dalmaz Mar 13 '13 at 23:21
  • 'dmesg |grip PHP' gives an empty list. I'm not using an lampp installed from ubuntu repositories, but a tar.gz extracted to /opt/lampp/. Maybe that version has some pecularities, I'll try the Ubuntu one. – Dalmaz Mar 13 '13 at 23:28
1

OK, resolved. Thanks for your help, Triskelion - thanks to you, I understand xampp better. There were two things 1) xampp giving no error messages. After looking in vain for error messages, I upgraded to xampp 1.8.0, and when I tried to get to the page that caused problems, I got a full error message.

 Additional uncaught exception thrown while handling exception.Original ODOException: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away: SELECT * FROM {system} WHERE type = &#039;theme&#039; OR (type = &#039;module&#039; AND status = 1) ORDER BY weight ASC, name ASC; Array ( ) in system_list() (line 165 of /opt/lampp/htdocs/twotrees/includes/module.inc). Additional 
PDOException: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away: SELECT ff.* FROM {filter_format} ff WHERE (status = :db_condition_placeholder_0) ORDER BY weight ASC; Array ( [:db_condition_placeholder_0] =&gt; 1 ) in filter_formats() (line 409 of /opt/lampp/htdocs/twotrees/modules/filter/filter.module).
Uncaught exception thrown in session handler.
PDOException: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away in _drupal_session_write() (line 209 of /opt/lampp/htdocs/twotrees/includes/session.inc).

Still, no messages in error_log. Where should I look for them?

2) I searched through the web, and found similar problems for example [http://drupal.org/node/1542432]. It turned out this is a XAMPP mysql memomry limit problem. I changed the value 'max_allowed_packet' to 100M in 'my.cnf'.

My site works now. I was really scared!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.