I'm using the Salesforce module in Drupal 7 and am attempting to create a mapping to one of my content types that contains a Location module field. After looking at both modules, I don't see an existing integration for them.

I tried adding a field mapping for just the street address (the only method available was using a token, so I selected [node:location:street]). When I kick off the import of salesforce data, I get the following error:

WD Salesforce Pull: Unknown data property [node. Processing failed for entity XXXXXXXXXX
associated with Salesforce Object ID: XXXXXXXXXXXXX

I tried other variations of the token, too, including:



Both gave me the same error.

1 Answer 1


It's difficult to say what's the exact problem, but I think you could have unmapped property in your configuration. So please go to /admin/structure/salesforce/mappings and verify all the objects that have the properly set mappings and the tokens are valid.

If this doesn't help, try the following options:

  1. Clear the cache (including memcached).
  2. Check watchdog logs for further info.
  3. Double check your Salesforce mappings again if you didn't miss anything.
  4. Upgrade your Location and Salesforce module to development version just to test.
  5. Look for any existing issues.
  6. Debug the code using xdebug.
  7. Report the issue or bug report on Drupal site against the right module.

You may also try the following related links:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.