0

I've downloaded the drupalcommerce kickstart but when adding a contextual filter to my view, the "exclude" option is missing.

when I expand the "more" at the bottom the only options are: Allow multiple values and administrative title

do I have to enable the option somewhere before I can access it?

I'm trying to make a list of nodes of the same type, excluding the current node... enter image description here

  • Did you ever figure out why this is happening? I'm having the same problem. Exclude appears when I use some fields for filtering, but not for others. Not for the one I need it for, of course. – Menno van den Heuvel Oct 25 '13 at 11:58
0

The exclude option is a part of the views_handler_argument_numeric handler that comes with views. If it's not there, it likely means your filter is operating on something other than a numeric argument. What you have is "Indexed Node: Node ID". If you create a filter on "Content: Nid" instead then you should see the option.

Also see https://www.drupal.org/node/733686 .

  • Although this seems like the most logical answer I can not confirm this a 100% as I am no longer working on the project and I don't have time to do a new setup. – mars Feb 25 '15 at 19:15
0

In the configuration screen for your Conceptual filter, go to the bottom and click on More, then select Exclude. There is no other way that I know of, and there is no option to activate it.

Make sure that the install of the Views module is clean and the most up to date version, and run update.php to make sure that all updates have been done. then look for it again.

  • sorry that doesn't help much... I know where it's supposed to be but the option is just missing... update.php claims everything is up to date... I put a screenshot of what I'm seeing in the question... – mars May 31 '13 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.