8

When trying to run `Drush pm-update' in a site i get the error

Command pm-update needs the following modules installed/enabled to run: update.                              [error]
The drush command 'pm-update' could not be executed.

Oddly this command was recently working (on other sites in the same core installation), and further more I have no idea where to find or what is this 'update' module. Can anyone point me in the right direction?

17

It's in <drupal_root>/modules/update. If not, it means you damaged your core.

Try drush en update - it should re-enable it for you. After performing updates you are allowed to disable it again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.