0

I just updated Apache Solr Search module to 7.x-1.4 version, and since then the facets are missing in the assigned region.

Facets of all taxonomy terms are missing, the rest of the default facets like content type, etc are appearing on the settings page.

Plus the Taxonomy term fields are missing under Bias settings as well.

I have tried to disable > Uninstall > re-install all the Apache solr search and Acquia search modules but Facts are not appearing back on the Apache Solr Settings page.

I have this issue on the production server.

Regards, Anand

1

Just wanted to log the answer that is suggested on Drupal.org: https://drupal.org/node/2123683, since this question is the first thing that popped up when I ran into this issue. :0)

Here is the issue: the taxonomy facets are the ones affected by the upgrade, because even though your taxonomy terms are probably hidden in the 'Search index' view mode on your content type's configuration page, apachesolr used to ignore those settings (a bug).

The new update fixes that, which means you need to go back to your content type's manage display page -> search index tab -> make sure the taxonomy terms in question are not hidden.

Hope this helps!

  • "the taxonomy facets are the ones affected by the upgrade, because even though your taxonomy terms are probably hidden in the 'Search index' view mode on your content type's configuration page" Saved me ! – JudaPriest Nov 4 '14 at 7:26
  • So glad it helped! :) – Boriana Ditcheva Nov 13 '14 at 22:45
0

Updating to latest release solved the issue.

  • Oh strange! I experienced the issue when upgrading to 7.x-1.6 – Boriana Ditcheva Feb 3 '14 at 15:45
  • Also the other strange thing is.. some of the facets disappear automatically... and later I have to re-enable the facets blocks on to the search results page. – AnAnD Feb 5 '14 at 8:10
  • I think the facets block disappear when the Acquia related module is updated, specially with the Acquia Search module – AnAnD Feb 5 '14 at 8:12
  • Thanks, @AnAnD, I also got them back by just re-enabling in the blocks admin page. Weird! – Boriana Ditcheva Feb 5 '14 at 19:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.