1

I enabled the blog module on a website, after that the site crashed. The error is the same on everypage:

Catchable fatal error: Argument 2 passed to entity_views_field_definition() must be an array, null given, called in /homez.653/xxxxxxxxx/www/sites/all/modules/entity/views/entity.views.inc on line 152 and defined in /homez.653/xxxxxxxxx/www/sites/all/modules/entity/views/entity.views.inc on line 175

Problem is that I don't have any backyp of the DB......

Any any idea on what should I do?

Thanks you per advance.

4
  • 6
    if you have access to your database via mysql or other means, take a look at the system table and look for modules/blog/blog.module in the filename field and change the status field in that row to 0 from 1 and hope for the best :)
    – Jimajamma
    Aug 30, 2013 at 2:16
  • @Jimajamma why isn't it an answer? Jean-Christophe Kleinbourg consider installing Backup and Migrate and enabling daily backups (hourly for development). I know now it's to late, but it can help in the future.
    – Mołot
    Aug 30, 2013 at 9:49
  • @molot, it's a comment because I am making the assumption that the OP is really asking how to manually disable the blog module in the DB, not how to go about debugging to make it work with the Entity API module.
    – Jimajamma
    Aug 30, 2013 at 12:11
  • Thanks, I tried Jimajamma solution, but it didnt work. In the future I will take care of making backups before touching anything.
    – jck
    Aug 31, 2013 at 4:43

1 Answer 1

1

The mention of "I do not have a backup of the DB" in the question/title makes it clear that you want to roll-back the change as opposed to debugging and making the modules work where it is - for that, you do not need a backup, but access to the code and logs.

Another way to bypass the blog module, an alternative to what @Jimajamma said is to remove the module from the filesystem. Remember to clear the cache and ideally rebuilt the module registry after these steps.

drush cc all --yes;
drush rr;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.