1

In my view I am exposing two sort options in the following order: Date > Newest First Title > A-Z

When both sort options are exposed it will correctly display the nodes sorted by date but will randomly sort the nodes by title. So for example titles starting with a R will appear for nodes which have titles starting with a D. When I turn off exposing the Title sort it will display correctly. First sorted by date and correctly sorted from A to Z. But I do need to expose the Title sort. So what am I missing? Or is it just a bug?

My Views settings My view settings

Sort settings date field Sort settings date field

Sort settings title field Sort settings title field

0

It's not a bug. Node creation date is stored with hours, minutes and seconds. If you are sorting by creation time, only nodes created in the very same second will ever use secondary sort criteria - Unless you will set granularity: enter image description here

3
  • Thanks, but the date field I'm using is not the Node creation date. It's a custom (date) field which offers no 'Granularity' when configuring the sort criterion. Your solution also doesn't explain why the sort is correct when I turn off exposing the title field.
    – rroose
    Sep 3 '13 at 7:03
  • @rroose So please post screenshots of how you configured fields and filters in question. Without them all I could do was to assume defaults.
    – Mołot
    Sep 3 '13 at 7:07
  • I've added screenshots.
    – rroose
    Sep 3 '13 at 7:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.