0

Recently I created a new Content type and Added a bunch of CCK fiekds in it. After that I migrated some contents to the system using node_save() function.

Everything was fine until I cleared the cache then 3 of my existing views broke and started to say "Views Broken/missing handler" in some of the fields and in filters. Though the fields do exist as the CCK fields in the proper content type.

  1. See the attached image This image shows the error in my views
  2. When I try to remove or modify the field then it says "An illegal choice has been detected. Please contact the site administrator." Also the field formats is not show. Refer to the below image. Blank format
  3. These fields though exist in the CCK as per the below image. Existing field
  4. To make the site working again I have to go to the Content type's Manage Fields page and click on save. Then it starts to show in proper way (Followed: https://drupal.org/node/624826). The problem is if I clear cache then again this happens.
  5. I had backed up the database before the migration and once I saw this then I DROPPED the total database and again imported the sqldump in the blank database but then again once I cleared the cache it again showed Broken/missing handler.

I am totally confused here. Searched Google but didn't got a proper solution. After dumping the old database still its happening. Is it that Views and CCK is storing something while I created the CCK? We are using Memcache in the system, but I suppose that has nothing to do with it.

Please help me on this.

  • I haven't used Views 2 in quite some time, but given you are seeing issues with caching, I'd check to make sure both Views and CCK are still caching correctly with memcache. Views 3 for example stuffs lots of stuff into the cache_views table with a cid of views_data:en' (for English anyway) and CCK stores all manners of corresponding data in the cache_content` table in the content_type_info:en cid (again for English). If there is any way to turn off memcache, clear caches etc and see if the problem goes away might be a good first start of debugging. – Jimajamma Sep 8 '13 at 14:43
1

I have found that MAX OPEN FILES can have an impact along with maximum size of object, my understanding is this is the case with or without memcache but I have not proved that yet. I created a tool with cURL to log broken views when they occur and use Munin to monitor everything as it happens: https://drupal.org/node/89710#comment-8351855

0

Just rearrange the order of you content type fields(temporary change) and then save it. That should force a refresh of the field cache. It solved my problem.

  • I try this but not worked. ( I work on drupal 6.22) – Yusef Sep 12 '15 at 7:01
0

I had the same issue, disabling views caching and cache clear solved my problem.

Disable views cache - admin -> structure -> views -> settings -> advanced -> disable views caching

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.