1

I'm positive I've successfully done this before but in testing a project today from a localhost Development (Ubuntu) to a live Production server (shared server, general market provider ala Bluehost) I'm getting a White Screen Of Death (WSOD) after importing the main filename.sql via phpmyadmin and I'm not sure why it's not working correctly.

Here's what I'm doing:

1) - copy via FTP all core and /sites/modules and my relevant dir contents.

2) - setup all Database with user/passwords including Admin as required.

3) - install generic Drupal v.7.2x onto server using Drupal /install.php

this then gets me a 'Standard' install but without all my data content but all accessable as per a generic standard Drupal install.

Next, back to phpmyAdmin, go to the relevant DB structure and chose 'Import', because I'm using a raw. sql I can just select the 22.5mg .sql file and wait, then I get the 'Success' message. I cannot use Backup & Migrate (M&G) Module due to the file limitation given my B&M.

After this point, I get a WSOD and cannot move forward.

The only thing I know that is different is that on my locahost Dev I used a simple 'Admin' name and a simple Password such as 'DeadEasy'. On the live Prod site, I changed this for better security to a name relevant to a SuperUser (ie AlphaBravoCharlie,(thats NOT real!!), Password: such as "DrG6%7DyE".

FYI, I did have some Fatal Errors yesterday based on Memory allocation, (I'm allowed 128meg max) but the example highlighted here is after I reduced module load to resolve the previous fatal error given.

Can anyone shed any light on what may have happened?

Notes #1: I had thought it may have been that I hadn't uploaded my 'sites/all/themes', but it wasn't. #2 any other 'test' index.html work fine (as in temporarily disabling the index.php).

  • You need to check the logs really. Probably a missing module or an error in sites/default/settings.php. The log file will tell you why you are WSOD. Do you have SSH to bluehost? – Queenvictoria Oct 22 '13 at 3:01
3

The first place to look would be the BlueHost Error Logs; their article at https://my.bluehost.com/cgi/help/562 describes where to find them within cPanel. If you're seeing failed calls to functions / modules that you know exist in your codebase, there's a strong probability that Drupal's registry is not current.

Drupal caches extension (module and theme) file locations within its registry. Given that you are importing an existing site database into a different structure, those locations are out-of-date.

If you haven't already, I suggest installing Drush (the DRUpal SHell) using the instructions at https://drupal.org/node/1181480

Then, clear the site cache:

drush cc all

If that does not clear it up, the next step is a registry rebuild. This forces Drupal to rescan executable file locations. Install the Drupal contrib project registry_rebuild using the instructions on the project homepage, then

drush rr

to rebuild the registry.

  • Thanks Guys, I'll follow your advice and post result here. – Paul B Oct 22 '13 at 21:10
  • 1
    I managed to resolve this issue. I'd say the issues were from a combination of max memory of 128meg which I resolved by turning off suggested UI items (Views, etc) which helped reduced my .sql file, but still down to 22meg. I couldn't use Backup & Migrate and in the end had to use phpMyAdmin to import to DB. I also think I a 'mismatch' with the settings.php for the user admin account details as they were still set to a 'vanilla' Admin, simple PW combination. I also changed the settings in the Current PHP version v5.5 so that upload memory was to 32meg. Then it all worked fine. – Paul B Oct 22 '13 at 22:36
  • Fantastic, glad to help! – jonpeck Oct 22 '13 at 23:01
1

If the MySQL file is too large for the web host's limits in phpMyAdmin, consider using the BigDump script. Download & edit the BigDump PHP file, then run from a web browser at: http://www.yourdomain.com/dump/bigdump.php to upload the MySQL in a staggered manner to get around the time-out limits. This requires the "Drop Table" setting on the original MySQL export file to be used in the database transfer. Also, make sure to use PHP 7.2+ settings for Drupal 8 at Bluehost.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.