0

On any content I create the formatting shows in the WYSIWIG editor but does not show up on the rendered page. I have tried to put it into each filter format ( Full HTML, Filtered HTML, Plain text ) with no change. So to make it really clear what is happening: I create and article with the body set as

<span>Test Content</span>
<p>More test Content</p>

or

Test Content

More test Content

and save it. Upon viewing the rendered page at the node url all of my content is pushed together and the HTML tags are gone completely when viewed in the inspector

Test ContentMore test Content

Would be what I get out. The weird thing is that if I go into the editor for the content the HTML tags and/or line-breaks are still there.

url of node with issue:

http://cafemam.b.fgqa.net/node/3575

1
  • I changed the view format output for one of my pieces of content (articles) with a positive effect - it was set for "Content" under "Format", I changed it to "Fields". Now the Articles in that view display their HTML correctly. How do I get this to change for the Articles and Basic Pages that are displayed in their default way ( without a view )? – DrCord Oct 25 '13 at 19:00
1

If text format is correct and filters are correct, verify that the display format of your both content types (Article & Basic Page) is not set to Plain text but Default (or Summary or trimmed, ...).

It is under Structure > Content Types > Basic page | Article > Manage Display > Body field (format column).

1
  • Thanks for the helpful answer, this led me to the place where it was set incorrectly. The default was set for "Default", but a custom type of article that was in use was set for "Plain Text". – DrCord Oct 28 '13 at 16:06
0
  • (although mentioned) Make sure the "Text format" for the node body is set to "Full HTML"
  • After that, make sure the cache is clear when viewing the saved node.
  • You could also check the "Full HTML" text format here: admin/config/content/formats/full_html to make sure you have access and it has the correct input filters assigned.

That should do it.

6
  • Nope, I already went through and did each of those things in turn, going back and checking them at least twice as they are the obvious reasons this might occur. – DrCord Oct 25 '13 at 15:07
  • Thanks though, these are the correct first things to check in a problem such as mine, good answer just not my answer :D – DrCord Oct 25 '13 at 15:14
  • No matter what I set the settings for the filter format to I cannot get it to not strip the HTML tags completely out of content... – DrCord Oct 25 '13 at 15:22
  • I have also tried reverting my theme to a stock theme with no effect. – DrCord Oct 25 '13 at 15:23
  • Also, custom blocks I save output the HTML saved in them just fine, they are using the Full HTML format. The problem only seems to effect "Articles" and "Basic Page" – DrCord Oct 25 '13 at 17:07
0

I ran into this on our new Drupal 7 install. The default of "Filtered HTML" has a very limited set of tags, including a limitation on h1..h6, which prevents headings from being displayed correctly.

0

You need to make it clear that the tags you don't want stripped are allowed content in the CKEditor WYSIWYG editor.

To set these variables, navigate to Configuration → Content authoring → CKEditor and then press edit for the profile you want to configure. Expand Advanced options, and type the JavaScript directly into the textfield Custom JavaScript configuration as shown in the screen shot below (disregard the first line unless you also want to set custom format_tags);

Below is an example (I don't allow h1 because Drupal uses it for page headings).

enter image description here

PS: If you Google this, you'll often see the following JavaScript suggested to "fix" the disappering tags problem:

config.allowedContent = true;

Yes, it will fix the problem of tags disappearing. But it will also make all sorts of content allowed - which is a gaping security hole in your site if you allow untrusted users to create and edit content. Don't use this quick "fix". Use the solution that uses the extraAllowedContent directive to spell out exactly what shall be allowed (and allow only safe content).

0

There is a quick fix if you need to get the page up right away but are struggling to have the tags stay.

Select your page and edit - I am assuming you are not filtering the HTML which strips even the most basic elements by default.

  1. Select the "Source" Button
  2. Edit the HTML
  3. Save (do not go back to view the result in the editor)

Now you can test your page from your site - the code should work. The problem is that every time you "Edit" the page the code will be removed.

I was hoping that Configuration/CKeditor/(edit full profile)/security/Full HTML -Configure ..... option would allow me to set a security group that would be able to do anything but I have not been able to get that to work.

I agree with the security concern of allowing all sorts of tags to be embedded but what if you want to load scripts? Still new to Drupal so I am open to ideas.

1
  • This seems like a really poor solution. – DrCord Jan 14 '15 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.