3

Using Secure Pages, I checked the option to have the site always be using HTTPS when logged in as an administrator, but now I have an infinite redirection issue, and I cannot log-in and navigate the site, leaving me to edit the settings manually.

How do I "uncheck", or revert the option that I selected manually in SecurePages?

2

I pulled this directly from the README.txt of the module.

Configuration

Generally on test/development servers you do not have access to SSL, so generally you would like to disable secure pages on these systems.

To do this add the following to your settings.php

$conf['securepages_enable'] = 0;

Removal of SecurePages

In the case where your SSL mode has been disabled and you can no longer access the administration section of your site to disable securepages you can do one of the 2 following things.

  1. Use the above method to disable securepages.
  2. delete the secure pages module from your site.

If you can use the first option but if you can't edit your settings.php then deleting it will not break your site, but will leave some variables that are set by secure pages.

  • Hmm. Unfortunately, that doesn't seem to have fixed the issue. Do you have any more ideas? I really appreciate the help, by the way. Would I have to modify securepages_roles? – Nathan Lutterman Oct 30 '13 at 19:52
  • try securepages_switch instead, updated my post. One of those variable controls whether your site uses secure pages or not. – Scott Joudry Oct 30 '13 at 19:53
  • new answer for you... – Scott Joudry Oct 30 '13 at 20:02
  • 1
    Haha! That did it, thank you, sir. I totally looked right over the readme. Gotta remind myself to RTFM. – Nathan Lutterman Oct 30 '13 at 20:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.