I can't seem to get my markers to come up in the Gmap module - I've changed permissions, I've checked the gmap_markers.js file, etc.

The map itself comes up, but I can't get any markers to appear.

What could cause this?

Could it be permission settings on my /default/files directory?

  • are there any javascript errors?
    – jdu
    Jan 20, 2014 at 14:44
  • Not that I saw. I'll double check after work tonight, and also write down what my macro is. The page is andrewjalexander.com/travel - I'm just trying to put down a few markers of different places I've visited and/or lived.
    – Jack Ryan
    Jan 20, 2014 at 14:54
  • [gmap markers=red::42.333302, -83.048401 |zoom=5 |center=42.333302, -83.048401 |width=800px |height=600px |control=Small |type=Hybrid] No Javascript errors.
    – Jack Ryan
    Jan 21, 2014 at 2:30
  • are you using custom markers? and a dumb question: are you sure that the map's javascript is firing on page load?
    – jdu
    Jan 21, 2014 at 14:13
  • I am not using custom markers, no. The map is popping up, so I would assume yes. Or are you asking about whether it is firing on page load specifically - if so, I'm not sure, but can check.
    – Jack Ryan
    Jan 21, 2014 at 15:26

2 Answers 2


This question is obviously very old, but I spent the last few hours figuring out the same issue and figured this might help someone else who is Googling this problem.

The problem for me was this:

In Modules, "Location Entity" should NOT be enabled. "Location CCK" (in the Fields section) should be.

Then, when modifying the Content Types, do NOT rely on the "Location" field that is there by default (machine name = locations). You have to add your own, additional Location field (field type = Location; widget = Location Field).

This solved the problem for me. I created a View (Page) for a Specific Content Type with Format = GMap and Data Source = Location.module.

Then it finally worked! Hope this helps.


I looked everywhere for a way to fix this issue for me, and none of the answers I found worked. So I thought I'd post my solution here, in case it might help someone else in future. My problem was simply that I had the theme_debug variable set to 1. As soon as I turned theme debug back off, all my markers worked again! With drush you can just do (in Drupal 7) "drush vset theme_debug 0". That fixed my issue!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.