1

Today I realized, that all images, that are located in sites/default/files/fields may not be accessed anymote, neither are they shown in my articles nor may I see them in the browser (e.g. http://daniel-stein.com/node/210#). All I get is a 403 - no permission - error. The folder and the files within are all set to 744 (and I also tested 777). I have not found any permissions I could adjust and I am not sure when this started or what I changed in that moment. Maybe it was around the time I changed from buedit to ckedit but the switch back was also useless.

  • have you checked the settings for your public files folder path in admin/config/media/file-system? It may not be set to sites/default/files – autopoietic Dec 19 '14 at 11:45
  • Public is set to sites/default/files - so I think it is correct... – Daniel Dec 19 '14 at 11:48
  • is the .htaccess file present in sites/default/files? – autopoietic Dec 19 '14 at 11:50
  • Yes, there is one (and I have not modified it). – Daniel Dec 19 '14 at 11:53
  • I notice that the image referenced is created as a derivative image (ie in a styles directory). Have you verified that the generated image is present at that location? – autopoietic Dec 19 '14 at 12:00
0

Ok, so I found a solution that worked for me.

In the process of investigating in this problem and the fact why it does not appear on other Drupal installations I have running on the same server I messed up the permission settings on my server. In order to reorder things, I installed the module https://www.drupal.org/project/security_review - it produces a list with potential security problems of your Drupal installation. I worked myself down the list solving the issues one by one. I am not sure if this was the point in the beginning but after I changed the permissions of the .htaccess-file in sites/default/files to 444 (readonly) suddenly my images were accessible again.

For your reference, here are a lot of other approaches you can try if the one I presented is not helping: https://www.drupal.org/node/1170440

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.