1

While creating a new view and after added the specific content to it.It's not showing the content which I've created instead it's showing

"no front page content has been created "

Error

  • what kind of view did you created? if it is a block, you need to set it first to show in front page. if it is a page, then your on the wrong page. – user3278675 Feb 12 '15 at 5:52
  • It's a page actually.but i've created only one page as of now.then what should i do now? – Prabakaran Eswaramoorthy Feb 12 '15 at 5:55
1

create a basic page or article and promote to front. or

  1. create view
  2. go to " configuration>site information"
  3. input path of the view I just created as a default front page.
    • you can see the PATH on View list ( structure > views)

I am using drupal 7.

" Welcome to YOUR SITE NAME " and " No front page content has been created yet." message are gone !

or in D7, I personally have used and like two edits in my theme's 'page.tpl.php' template:

1.) To remove the default message, anywhere within the page is added

<?php if(drupal_is_front_page()) {unset($page['content']['system_main']['default_message']);} ?>

2.) To remove the default page title,

<?php if ($title): ?> is changed to
<?php if ($title && !drupal_is_front_page()): ?>

Alternatively, one could use a template override ('page--front.tpl.php') and specify this output to be omitted.

or refer this module https://www.drupal.org/project/empty_front_page

or You don't need to add modules for small changes: you can override your template file and add the followning code :

function MYTHEME_preprocess_page(&$vars) { 
if (drupal_is_front_page()) { 
unset($vars['page']['content']['system_main']['default_message']); //will remove message "no front page content is created" 
}

refer this link for more https://www.drupal.org/node/1049290

  • Right now i've deleted all the content related to the view and also the view.Still it's showing the same error.and more over i've created a new view and added my custom content to it.in view's preview it's showing all the contents i've added but in actual it's showing no content shows only the title. – Prabakaran Eswaramoorthy Feb 12 '15 at 6:05
3

Go to "admin/config/system/site-information" to set front page.

Bottom section of this page there is a option for set "Default front page".

Give the view link in "Default front page" textbox. You will not able to see that message.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.