I'm using Entity Translation and I've enabled "Enabled, with field translation" in a content type but don't want to translate each individual field.

It seems "Field translation" of i18n suit does it and in translate interface at admin/config/regional/translate/translate we can translate the field labels.

But the problem (as in the photo) is that it shows the same field text for all the content types sharing same field with same label. That is for same label I should be able to translate once only.

enter image description here

Is there any more simple way to translate field labels at once?

A similar question is here: How to translate Boolean field labels? but seems to be more specific.

1 Answer 1


You need to download internationalization module and enable field_translation module which comes in this package. How to translate the field labels:

  1. Go to manage fields. For ex. Articles, the path will be admin/structure/types/manage/article/fields/
  2. Click edit for field_tags.
  3. You'll see a translate tab there. I have attached the screenshot.
  4. Translate field name and description there. It works.enter image description here
  • My problem was that English was not the source language. This can be changed at /admin/config/regional/i18n/strings (Multilingual settings -> Strings -> Source language)
    – cweiske
    Commented Jan 13, 2021 at 8:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.