3

My setup is as follows:

Drupal 7.34 Media 7.x-2.0-alpha3 CKEditor 4.4.6.08188c4

My problem is:

When I add an image from the "library" via media browser in CKeditor and try and link it via the "link" icon - the image does not link up. If I switch to source view I can see that no tags have been added. If I save page - image link is not applied.

However, the link is saved if I edit source and add link tags in manually.

example

3
  • Have you checked to see if there are any JS errors in the console?
    – Shawn Conn
    Jun 5, 2015 at 17:35
  • @ShawnConn - No console errors
    – Warren
    Jun 15, 2015 at 11:41
  • I've had similar issues/realizations. Can you remember if it WOULD add the <a> tags, but rather than surround the element in it, create two at each ends of the element that both opened and closed. So turning "<a>stuff</a>" into "<a></a>stuff<a></a>"? If so, I'm petty sure it's all about the media module tokens and using view modes. Mar 18, 2016 at 17:55

1 Answer 1

1

From the question details it is not clear if you're using the CKeditor module, or it you're using the WYSIWYG module in combination with the CKEditor library (so without the CKeditor module).

As a possible alternative to consider, I'd suggest you try this:

  • if you're using the CKeditor module, then replace the 4.4.6 ... version of CKeditor with some 3.6.x version of it (such as CKEditor version 3.6.6.1.7696), and see if your problem is resolved (the 4.x version is known to have "some" issues which don't exist in the 3.x version ...).

  • alternatively, use the WYSIWYG module (without the CKeditor module, but only using the CKEditor library with version 3.6.6, since WYSIWYG module does not support the 4.x version yet ...). In this case, you may also want to experiment with the various 'cleanup and output' options within /admin/config/content/wysiwyg/profile/your_txt_fmt/edit (with 'your_txt_fmt' the text format you're using, eg 'filtered_html').

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.