2

I have installed Webform and would like to add it to my custom content type. I have checked my content type under admin/config/content/webform and saved the webform settings but I still don't get the option to add a webform to my content type.

1
  • 1
    clear cache and check again if it works. and which version of webform are you using, make sure it is latest because I am not able replicate such issue in mine.
    – shrish
    Jun 11, 2015 at 4:38

2 Answers 2

2

Go to Content type edit page : /admin/structure/types/manage/[ContentTypeName]. There you can see the webform under the Menu Settings. Just enable it from there. Adding screenshot :

enter image description here

1
  • 2
    I don't see this tab on content type edit form even after enabling webform_node submodule using 8.x-5.0-beta9
    – GiorgosK
    Apr 18, 2017 at 18:14
2

To add a webform to your content type you should add a field to your content type and choose other as a type of this field ---> Reference /other then save after that when you choose the type of reference you must choose webform and save Now in your content type when you add content you find a field for your webform and in that you put one of your webform

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.