2

I installed these modules: Wysiwyg, IMCE Wysiwyg bridge, IMCE.

Then downloaded the libraries from:

https://www.tinymce.com/download/ (developer edition, community doesn't even have a non minified imce.js file...)

Now the file structure is not the same as the instructions from Drupal Backend:

Extract the archive and copy its contents into a new folder in the      following location:
sites/all/libraries/tinymce

So the actual library can be found at:
sites/all/libraries/tinymce/jscripts/tiny_mce/tiny_mce.js

So I deducted I had to change folder structure from:

sites/all/libraries/tinymce/js/tinymce/tinymce.js

To:

sites/all/libraries/tinymce/jscripts/tiny_mce/tiny_mce.js

But still not working, I get this error:

TinyMCE (Download)  Not installed.
The version of TinyMCE could not be detected.
  • I think you should check the version of tinymce library you are you using. Please check the documentation of right version. – Dev Dec 10 '15 at 5:12
  • You may try using some older verion, or try version 3.5 or 3.4 – Dev Dec 10 '15 at 5:19
3

You need use the last dev version of Wysiwyg, you can read more about this here.

And you need read the Supported Editors Matrix.

I download the 3.5.11 version of TinyMCE from here and copy the tinymce folder to YOUR_SITE/sites/all/libraries/ so inside this folder you must have this:

enter image description here

So I have installed:

Wysiwyg 7.x-2.x-dev
TinyMCE 3.5.11

And it works ;-)

  • Ok, this worked finally...what a pain...I really like that "supported editors matrix" page at drupal.org/node/596966 that would have saved me hours...are there any pages like that that cover ALL compatibility issues for drupal modules and libraries? – Bruno Vincent Dec 10 '15 at 8:17
  • @BrunoVincent I don't know about other pages, and good luck with your project – Adrian Cid Almaguer Dec 11 '15 at 0:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.