2

I need a WYSIWYG editor so I installed drupal wysiwyg module in sites/all/modules folder. Further I downloaded TinyMCE and installed it in sites/all/libraries/tinymce.

The editor configuration is correctly displayed in admin/settings/wysiwyg/profile/2/edit. My interface language is German and TinyMCE has this language pack installed.

When I go to edit some text in the backend the editor itself is initialized but no buttons are displayed.

Any ideas why there are no buttons and how do I fix this?

4

Did you enable some button /admin/config/content/wysiwyg/profile/yourprofile/edit ?

If yes, this can be caused by a javascript error. Do you see one in Firebug ?

6
  • yes I enabled some buttons and there are no errors in firebug... – Lost in OWL Feb 16 '12 at 15:41
  • 1
    Well, seems like a tough one. Did you try to set the language to English (default) in TinyMCE options ? – Countzero Feb 16 '12 at 16:20
  • I notices that drupal includes jquery 1.2.6, maybe this version is too old for tinymce? – Lost in OWL Feb 16 '12 at 16:24
  • as a fruther notice, I tried other editors too, none of them showed the buttons – Lost in OWL Feb 16 '12 at 16:26
  • Setting language to english did the trick, thank you – Lost in OWL Feb 16 '12 at 16:30
0

Just to make this clearer since others may not read the comments...

Try to set the language to English and make sure that each filter configuration is set to English (in my case one was French and the other English)

0

Installation: Step 1: In Drupal 7, Download Tinymce (I've used TinyMCE 3.5.11 jQuery package) from here and save as like the actual library can be found at:

\sites\all\libraries\tinymce\jscripts\tiny_mce\jquery.tinymce.js

Step 2: Then reload the page and go to this location:

/admin/config/content/wysiwyg

Step 3: Now choose tinymce from 'Editor' column for your appropriate 'Text Format' and click on the 'Save' button.

Step 4: Click on the 'Edit' button of tinymce enabled 'Text Format'.

Step 5: Make sure 'Language' is English in 'Basic Setup' tab.

Step 6: By default all button and plugins are disabled. So enable your required button or plugins from 'Buttons and plugins' tab,strong text otherwise you'll not see any button in 'rich text' input mode. enter image description here N.B.: Step 6 is the main answer of the question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.