1

Okay, so ive reinstalled my ubuntu OS, reinstalled the LAMP stack, ive restored the database and connected to it just fine. Ive checked which php modules drupal 8 requires and installed them, my version of php is above the 5.6 lower limit - i have not installed ALL of the php5-* modules in apt-cache though but i dont think thats an issue(?), ive set the chmod 777 . But now my /user/login kind of routes dont work, it just gives a 404. Have anyone experience anything like this, and how to solve?

I have looked at the clean_urls in my .htaccess, but drupal 8 clean urls should just work out of the box.

  • I would advise using a VM to sidestep all of this setup, there are lots out there ready to go for Drupal that are configured appropriately. – Kevin Mar 9 '16 at 15:19
  • Well Ive fixed it now, i dont think its too much of hazzle to set up dev for drupal in general and i really do prefer not using vm's – DenLilleMand Mar 9 '16 at 15:45
1

Okay so i went inside of /etc/apache2.conf and changed

<Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride none
    Require all granted
</Directory>

to

<Directory /var/www/>
        Options Indexes FollowSymLinks
        AllowOverride all
        Require all granted
    </Directory>

that worked :)

  • Life Saver! I migrated Drupal from windows to Ubuntu and had the same issue. This solved it for me! – Joshua Kissoon Jun 29 '16 at 13:53
0

Did you check whether you have activated the mod_rewrite Apache module? According to the INSTALL.txt file for Drupal 8,

If you want to use Drupal's "Clean URLs" feature on an Apache web server, you will need the mod_rewrite module and the ability to use local .htaccess files.

  • mod_rewrite is enabled when i run phpinfo(), and i just found out that the clean urls actually work, as in: mydrupal/index.php/user/login ... so i have a feeling its something about the document root, im not really an expert on that area to say the least though. – DenLilleMand Mar 9 '16 at 12:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.