1

I have a 'blog' page that lists blog posts and a 'news/events' page that lists articles.

I cannot remember how they got there, if they were automatically generated. I think I had to do something at least for the articles page, but I cannot find anything about why mysite.com/news lists all the articles and how mysite.com/blog lists blog posts. I've looked through structure and content and views and don't see where this is coming from and I have no hover in the admin interface to edit the whole page (just individual posts). These pages seem not to have any titles set, either.

The main concern here is in the menu right now they are absolute links and I want to be dynamic, relative paths.. but I don't know what to put for that. I also need to make sure they properly get an 'active' state in the menu, which currently they do not!

  • Are the news/article and blog separate content types? (Not e.g. a taxonomy category?) Did you check every view to see if these paths are specified anywhere? – arjan Jan 14 '12 at 23:14
  • ah.. loks like my 'news' page is using the 'frontpage view' view.. and I'm guessing '/blog' is generated automatically, but how do I add these to a menu? they added themselves autmoatically to one menu, but I need them on a different one – Damon Jan 15 '12 at 1:11
  • I got it figured I think.. setting the paths to 'blog' and 'news' seems to have it working. – Damon Jan 15 '12 at 1:16
1

In Drupal 7, go to /admin/structure/menu/manage/ to manage your menus. Select "Main Menu" as that will probably be your primary navigation.

Click +Add Link. For both Blog and News, set the appropriate name in the "Title" field.

For path, set the Blog path to "blog" or for News you can set it to "home" to retrieve articles promoted to the front page, or something like "news" if you have a specific page with a path set to that for those articles to be displayed on.

  • 1
    This is basically right and I got it working.. however one of the hiccups was that I had '/blog' and it needed to be 'blog' – Damon Jan 16 '12 at 5:58
  • That was my mistake. Apologies! Glad you got it working. – David Csonka Jan 17 '12 at 17:32
  • 1
    correct the slash so I can mark you correct? ;) – Damon Jan 17 '12 at 19:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.